package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:(?:https?|ftp):\/\/|www\.)[-a-z0-9+&@#\/%?=~_|!:,.;]*[-a-z0-9+&@#\/%=~_|]`)
var str = `https://virtual.prueba.ungs.edu.ar/grado/moodle/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}