re = /\b(?:(?:https?|ftp):\/\/|www\.)[-a-z0-9+&@#\/%?=~_|!:,.;]*[-a-z0-9+&@#\/%=~_|]/m
str = 'https://virtual.prueba.ungs.edu.ar/grado/moodle/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end