const regex = new RegExp('([a-zA-Z_](?:[a-zA-Z0-9_])*)\\s*=\\s*(\\d+|(\\+\\+|--|\\*\\*|//)?((?:[a-zA-Z_](?:[a-zA-Z0-9_])*))|(?:[a-zA-Z_](?:[a-zA-Z0-9_])*)(\\+\\+|--))$', 'gm')
const str = `k=++g677
k=--j77
kasd =++gfrf677frfr
k = 5
as = k++
a++
++a
k=++@ff`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}