$re = '/\d,\d{3}(?= [\d,.]+\location)/m';
$str = 'Location: Bangalore
Duration: 12+ Years
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);