re = /\d,\d{3}(?= [\d,.]+\location)/m
str = 'Location: Bangalore
Duration: 12+ Years
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end