#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?!(?:Mc|De)[A-Z])(\w*?[a-z])([A-Z])"
Local $sString = "Match: camelCase" & @CRLF & _
"Match: NewsToday" & @CRLF & _
"No Match: IBM" & @CRLF & _
"No Match: McDonalds (matches pattern above)" & @CRLF & _
"No Match: DeSanto (matches pattern above)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")