$re = '/\b(?!(?:Mc|De)[A-Z])(\w*?[a-z])([A-Z])/m';
$str = 'Match: camelCase
Match: NewsToday
No Match: IBM
No Match: McDonalds (matches pattern above)
No Match: DeSanto (matches pattern above)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);