package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9a-z]{5}`)
var str = `ds5tf
about
sales
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}