$re = '/^[0-9a-z]{5}/m';
$str = 'ds5tf
about
sales
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);