const regex = /\[rilevante\](.*?)\[\/rilevante\]/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[rilevante\\](.*?)\\[\\\/rilevante\\]', 'mg')
const str = `[rilevante]
Titolo: Mancini: “Fondazioni e Associazioni sono fondamentali per lo sviluppo dei territori”
URL: https://assifero.org/mancini-fondazioni-e-associazioni-sono-fondamentali-per-lo-sviluppo-dei-territori/
Data di pubblicazione: 11 settembre 2024
[/rilevante]
[analisi della rilevanza]
L'articolo è rilevante per Junior Achievement Italia per diversi motivi. Innanzitutto, parla dell'importanza di fondazioni e associazioni nello sviluppo dei territori, un tema strettamente connesso alla missione di Junior Achievement Italia di coltivare competenze imprenditoriali e promuovere lo sviluppo locale. La presenza della Presidente di Assifero al Festival Nazionale dell’Economia Civile rafforza ulteriormente questa connessione, evidenziando il ruolo centrale delle organizzazioni no-profit e delle fondazioni nella creazione di un'economia sostenibile e inclusiva. Questi argomenti sono in linea con l'obiettivo di JA Italia di preparare i giovani ad affrontare le sfide del futuro attraverso l'educazione imprenditoriale e la collaborazione con diversi stakeholder.
[/analisi della rilevanza]
[bozza post linkedin]
🌟 Chi ha detto che solo le aziende possono fare la differenza? Le fondazioni e le associazioni giocano un ruolo fondamentale nello sviluppo dei territori e nella promozione di un'economia sostenibile e inclusiva!
📆 Dal 3 al 6 ottobre 2024, la Presidente di Assifero, sarà tra gli ospiti del Festival Nazionale dell’Economia Civile a Firenze. Questo evento si concentrerà su come un’Europa più sostenibile e aperta ai vari territori può emergere grazie alla collaborazione tra associazioni, fondazioni e altre organizzazioni no-profit.
💡 Come Junior Achievement Italia, crediamo fermamente che il coinvolgimento delle fondazioni e delle associazioni nella formazione dei giovani e nello sviluppo delle competenze imprenditoriali sia cruciale per preparare le prossime generazioni alle sfide del futuro.
👉 Uniamoci nel promuovere pratiche sostenibili e nella costruzione di un futuro migliore per tutti! Scopri di più sull'evento e sul ruolo delle fondazioni e associazioni nel creare un impatto positivo: [link articolo]
#EconomiaCivile #Sostenibilità #EducazioneImprenditoriale #JAItalia #FuturoDeiGiovani
[/bozza post linkedin]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}