import re
regex = re.compile(r"\[rilevante\](.*?)\[\/rilevante\]", flags=re.MULTILINE)
test_str = ("[rilevante]\n"
"Titolo: Mancini: “Fondazioni e Associazioni sono fondamentali per lo sviluppo dei territori”\n"
"URL: https://assifero.org/mancini-fondazioni-e-associazioni-sono-fondamentali-per-lo-sviluppo-dei-territori/\n"
"Data di pubblicazione: 11 settembre 2024\n"
"[/rilevante]\n\n"
"[analisi della rilevanza]\n"
"L'articolo è rilevante per Junior Achievement Italia per diversi motivi. Innanzitutto, parla dell'importanza di fondazioni e associazioni nello sviluppo dei territori, un tema strettamente connesso alla missione di Junior Achievement Italia di coltivare competenze imprenditoriali e promuovere lo sviluppo locale. La presenza della Presidente di Assifero al Festival Nazionale dell’Economia Civile rafforza ulteriormente questa connessione, evidenziando il ruolo centrale delle organizzazioni no-profit e delle fondazioni nella creazione di un'economia sostenibile e inclusiva. Questi argomenti sono in linea con l'obiettivo di JA Italia di preparare i giovani ad affrontare le sfide del futuro attraverso l'educazione imprenditoriale e la collaborazione con diversi stakeholder.\n"
"[/analisi della rilevanza]\n\n"
"[bozza post linkedin]\n"
"🌟 Chi ha detto che solo le aziende possono fare la differenza? Le fondazioni e le associazioni giocano un ruolo fondamentale nello sviluppo dei territori e nella promozione di un'economia sostenibile e inclusiva!\n\n"
"📆 Dal 3 al 6 ottobre 2024, la Presidente di Assifero, sarà tra gli ospiti del Festival Nazionale dell’Economia Civile a Firenze. Questo evento si concentrerà su come un’Europa più sostenibile e aperta ai vari territori può emergere grazie alla collaborazione tra associazioni, fondazioni e altre organizzazioni no-profit.\n\n"
"💡 Come Junior Achievement Italia, crediamo fermamente che il coinvolgimento delle fondazioni e delle associazioni nella formazione dei giovani e nello sviluppo delle competenze imprenditoriali sia cruciale per preparare le prossime generazioni alle sfide del futuro.\n\n"
"👉 Uniamoci nel promuovere pratiche sostenibili e nella costruzione di un futuro migliore per tutti! Scopri di più sull'evento e sul ruolo delle fondazioni e associazioni nel creare un impatto positivo: [link articolo]\n\n"
"#EconomiaCivile #Sostenibilità #EducazioneImprenditoriale #JAItalia #FuturoDeiGiovani\n"
"[/bozza post linkedin]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")