#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Leistung.*$(\n^Zusatz.*$)?"
Local $sString = "Leistung Armeotraining ET Anzahl 1" & @CRLF & _
"Zusatz *TextZusatz_Anf1*" & @CRLF & _
"Leistung Atemtherapie 30 Anzahl 2" & @CRLF & _
"Leistung Aktivierungsgruppe Anzahl 3" & @CRLF & _
"Zusatz *TextZusatz_Anf3*"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")