package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^Leistung.*$(\n^Zusatz.*$)?`)
var str = `Leistung Armeotraining ET Anzahl 1
Zusatz *TextZusatz_Anf1*
Leistung Atemtherapie 30 Anzahl 2
Leistung Aktivierungsgruppe Anzahl 3
Zusatz *TextZusatz_Anf3*`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}