import re
regex = re.compile(r"(?<=\n)\n\n", flags=re.MULTILINE)
test_str = ("Уильям Шекспир (William Shakespeare) родился 23 апреля 1564 года в Стратфорде-на-Эйвоне, графство Уорикшир в Англии. В приходской\n\n\n"
" книге сохранилась запись о его крещении 26 апреля. Отец, Джон Шекспир, был в Стратфорде видным\n\n"
" человеком (по некоторым данным, он торговал")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")