re = /(?<=\n)\n\n/m
str = 'Уильям Шекспир (William Shakespeare) родился 23 апреля 1564 года в Стратфорде-на-Эйвоне, графство Уорикшир в Англии. В приходской
книге сохранилась запись о его крещении 26 апреля. Отец, Джон Шекспир, был в Стратфорде видным
человеком (по некоторым данным, он торговал'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end