using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![_\p{L}])CAR_COMPONENTS_ADT(?![_\p{L}])";
string input = @"CAR_COMPONENTS_ADT CAR_COMPONENTS_ADT1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}