$re = '/(?<![_\p{L}])CAR_COMPONENTS_ADT(?![_\p{L}])/m';
$str = 'CAR_COMPONENTS_ADT CAR_COMPONENTS_ADT1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);