using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"very specific string (\[[^\]]+\])?\K.*";
string input = @"Lorem ipsum dolor very specific string [lorem]matchintent1
Lorem ipsum dolor very specific string matchintent2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}