re = /very specific string (\[[^\]]+\])?\K.*/m
str = 'Lorem ipsum dolor very specific string [lorem]matchintent1
Lorem ipsum dolor very specific string matchintent2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end