package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^()]+|[^()]+$`)
var str = `This is a test (with brackets) as you see.`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}