$re = '/^[^()]+|[^()]+$/m';
$str = 'This is a test (with brackets) as you see.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;