using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[d|e]{10})";
string input = @" >|title| information
asdfsdfsdfsasdfsdfsdfsasdfsdfsdfs
asseefadfefeeedddeeeedddasdfsdf
asdfsdfsdfsasdfsdfsdfsasdfsdfsdfs
asseefadfefeeedddeeeedddasdfsdf
>|title| information
asseefadfefeeedddedeedddasdfsdf
asseefadfeasdfsdfsdfsasdfsdfdfsdf
asdfsdfsdfsasdfsdfsdfsasdfsdfsdfs
asseefadfefeeedddedeedddasdfsdf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}