re = /(?:[d|e]{10})/m
str = ' >|title| information
asdfsdfsdfsasdfsdfsdfsasdfsdfsdfs
asseefadfefeeedddeeeedddasdfsdf
asdfsdfsdfsasdfsdfsdfsasdfsdfsdfs
asseefadfefeeedddeeeedddasdfsdf
>|title| information
asseefadfefeeedddedeedddasdfsdf
asseefadfeasdfsdfsdfsasdfsdfdfsdf
asdfsdfsdfsasdfsdfsdfsasdfsdfsdfs
asseefadfefeeedddedeedddasdfsdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end