#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d{2}:\d{2}:\d{2}[.,]\d{3})\s-->\s(\d{2}:\d{2}:\d{2}[.,]\d{3})\n(.*(?:\r?\n(?!\r?\n).*)*)"
Local $sString = "WEBVTT" & @CRLF & _
"" & @CRLF & _
"1" & @CRLF & _
"00:00:00.310 --> 00:00:02.540" & @CRLF & _
"Dans cette séquence, nous" & @CRLF & _
"allons voir pourquoi nos" & @CRLF & _
"" & @CRLF & _
"2" & @CRLF & _
"00:00:02.550 --> 00:00:05.210" & @CRLF & _
"assistants personnels," & @CRLF & _
"smartphones et tablettes, sont" & @CRLF & _
"" & @CRLF & _
"3" & @CRLF & _
"00:00:05.210 --> 00:00:07.420" & @CRLF & _
"devenus tout" & @CRLF & _
"naturellement, en une dizaine d'années" & @CRLF & _
"" & @CRLF & _
"4" & @CRLF & _
"00:00:07.420 --> 00:00:10.100" & @CRLF & _
"seulement, un point de collecte" & @CRLF & _
"majeur de données personnelles." & @CRLF & _
"" & @CRLF & _
"5" & @CRLF & _
"00:00:10.520 --> 00:00:13.140" & @CRLF & _
"Pourquoi le smartphone" & @CRLF & _
"intéresse-t-il tant de monde ?" & @CRLF & _
"" & @CRLF & _
"6" & @CRLF & _
"00:00:15.690 --> 00:00:17.550" & @CRLF & _
"Tout d'abord, il faut" & @CRLF & _
"être conscient que dans un" & @CRLF & _
"" & @CRLF & _
"7" & @CRLF & _
"00:00:17.550 --> 00:00:20.110" & @CRLF & _
"smartphone, 2 niveaux" & @CRLF & _
"existent. Il y a la partie visible" & @CRLF & _
"" & @CRLF & _
"8" & @CRLF & _
"00:00:20.150 --> 00:00:23.440" & @CRLF & _
"avec son processeur dont on" & @CRLF & _
"va vanter les performances," & @CRLF & _
"" & @CRLF & _
"9" & @CRLF & _
"00:00:23.440 --> 00:00:26.260" & @CRLF & _
"le système d'exploitation" & @CRLF & _
"- dans ce module, nous nous"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")