import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d{2}:\\d{2}:\\d{2}[.,]\\d{3})\\s-->\\s(\\d{2}:\\d{2}:\\d{2}[.,]\\d{3})\\n(.*(?:\\r?\\n(?!\\r?\\n).*)*)";
final String string = "WEBVTT\n\n"
+ "1\n"
+ "00:00:00.310 --> 00:00:02.540\n"
+ "Dans cette séquence, nous\n"
+ "allons voir pourquoi nos\n\n"
+ "2\n"
+ "00:00:02.550 --> 00:00:05.210\n"
+ "assistants personnels,\n"
+ "smartphones et tablettes, sont\n\n"
+ "3\n"
+ "00:00:05.210 --> 00:00:07.420\n"
+ "devenus tout\n"
+ "naturellement, en une dizaine d'années\n\n"
+ "4\n"
+ "00:00:07.420 --> 00:00:10.100\n"
+ "seulement, un point de collecte\n"
+ "majeur de données personnelles.\n\n"
+ "5\n"
+ "00:00:10.520 --> 00:00:13.140\n"
+ "Pourquoi le smartphone\n"
+ "intéresse-t-il tant de monde ?\n\n"
+ "6\n"
+ "00:00:15.690 --> 00:00:17.550\n"
+ "Tout d'abord, il faut\n"
+ "être conscient que dans un\n\n"
+ "7\n"
+ "00:00:17.550 --> 00:00:20.110\n"
+ "smartphone, 2 niveaux\n"
+ "existent. Il y a la partie visible\n\n"
+ "8\n"
+ "00:00:20.150 --> 00:00:23.440\n"
+ "avec son processeur dont on\n"
+ "va vanter les performances,\n\n"
+ "9\n"
+ "00:00:23.440 --> 00:00:26.260\n"
+ "le système d'exploitation\n"
+ "- dans ce module, nous nous";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}