package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\%)(?:[^!$|\W])`)
var str = `%252525253E%252553Csvg%25252525252525252Fonload%252525252525252525252525252525252525252525252525252525253Dalert(document.domain)%252525252`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}