re = /(\%)(?:[^!$|\W])/
str = '%252525253E%252553Csvg%25252525252525252Fonload%252525252525252525252525252525252525252525252525252525253Dalert(document.domain)%252525252'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end