package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\\n`)
var str = `Abc\n123!
Abc\n123\!
\n\t\r bfnrtv`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}