$re = '/\\\\n/';
$str = 'Abc\\n123!
Abc\\n123\\!
\\n\\t\\r bfnrtv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);