$re = '/, | (?!.*?, )/';
$str = 'Keratyna 5, egzon 2, Homo sapiens
101m_A mol:protein length:154 MYOGLOBIN';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);