re = /, | (?!.*?, )/
str = 'Keratyna 5, egzon 2, Homo sapiens
101m_A mol:protein length:154 MYOGLOBIN'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end