#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^\(\n]+)\(([^\)]*)\)(?:\s+--\s+(.*))?$"
Local $sString = "" & @CRLF & _
"changeDate(pPOSIXPath, pDateToChange, pNewDate) -- @Date @Finder @File @Change" & @CRLF & _
"checkReqdASVer(pVerReqdStr) -- @AppleScript @Ver" & @CRLF & _
"cleanName(pNameFinderItem) -- @Clean @File @Folder @Invalid @RegEx @Satimage @FileName" & @CRLF & _
"collapseList(pMultiList)" & @CRLF & _
"continueScript(pMsgStr)" & @CRLF & _
"convertASDateToNSDate(pASDate) -- @Date @NS @ASObjC @Convert" & @CRLF & _
"convertISOtoDate(pDateStr) -- @Date @ISO @String" & @CRLF & _
"convertToDate(pDate) -- @Date @Convert @String" & @CRLF & _
"copyHTMLasRTFtoClipboard(pstrHTML)" & @CRLF & _
"createAliasIcon(pstrIconFile)" & @CRLF & _
"createHTMLLink for Params -- Params is a record" & @CRLF & _
"doesItemExist(pPOSIXPath) -- @Path @File @Finder @ASObjC" & @CRLF & _
"existsFinderItem(pPathStr)" & @CRLF & _
"expandPath(pPOSIXPath)" & @CRLF & _
"extractIndex(pList, pStartDelim, pEndDelim) -- @List @Index @Delim" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")