import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^\\(\\n]+)\\(([^\\)]*)\\)(?:\\s+--\\s+(.*))?$";
final String string = "\n"
+ "changeDate(pPOSIXPath, pDateToChange, pNewDate) -- @Date @Finder @File @Change\n"
+ "checkReqdASVer(pVerReqdStr) -- @AppleScript @Ver\n"
+ "cleanName(pNameFinderItem) -- @Clean @File @Folder @Invalid @RegEx @Satimage @FileName\n"
+ "collapseList(pMultiList)\n"
+ "continueScript(pMsgStr)\n"
+ "convertASDateToNSDate(pASDate) -- @Date @NS @ASObjC @Convert\n"
+ "convertISOtoDate(pDateStr) -- @Date @ISO @String\n"
+ "convertToDate(pDate) -- @Date @Convert @String\n"
+ "copyHTMLasRTFtoClipboard(pstrHTML)\n"
+ "createAliasIcon(pstrIconFile)\n"
+ "createHTMLLink for Params -- Params is a record\n"
+ "doesItemExist(pPOSIXPath) -- @Path @File @Finder @ASObjC\n"
+ "existsFinderItem(pPathStr)\n"
+ "expandPath(pPOSIXPath)\n"
+ "extractIndex(pList, pStartDelim, pEndDelim) -- @List @Index @Delim\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}