const regex = /\[click here]\(http[^()]*\)(*SKIP)(*F)|(?:https?:\/\/)?(?:[^.]+\.)?momento360\.com\/e\/(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[click here]\\(http[^()]*\\)(*SKIP)(*F)|(?:https?:\\\/\\\/)?(?:[^.]+\\.)?momento360\\.com\\\/e\\\/(.*)', 'gm')
const str = `[click here](https://momento360.com/e/uc/1478291a8dd94a8198339f1ffe4b97be?utm_campaign=embed&utm_source=other&size=medium)
https://momento360.com/e/u/a9b53aa8f8b0403ba7a4e18243aabc66
https://momento360.com/e/uc/1478291a8dd94a8198339f1ffe4b97be?upload-key=e84e1fb3567546a885a2a223bde6ef32`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}