re = /\[click here]\(http[^()]*\)(*SKIP)(*F)|(?:https?:\/\/)?(?:[^.]+\.)?momento360\.com\/e\/(.*)/m
str = '[click here](https://momento360.com/e/uc/1478291a8dd94a8198339f1ffe4b97be?utm_campaign=embed&utm_source=other&size=medium)
https://momento360.com/e/u/a9b53aa8f8b0403ba7a4e18243aabc66
https://momento360.com/e/uc/1478291a8dd94a8198339f1ffe4b97be?upload-key=e84e1fb3567546a885a2a223bde6ef32'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end