# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)\.getModification\(\s*[\"']([\w\-]+)['\"]\s*,\s*([\"'][^\"]*['\"]|[+-]?(?:\d*[.])?\d+|true|false|False|True)(?:\s*,\s*(?:true|false|\d+|\"[^\"]*\"))?\s*\)"
test_str = ("\n"
"val color = Flagship.getModification(\"btnColor\", \"#0e5fe3\", true)\n"
"val size = Flagship.getModification(\"btnSize\", 13, true)\n"
"val display = Flagship.getModification(\"displayBtn\", true, true)\n\n\n"
"val color = Flagship.getModification(\"btnColor\", \"#0e5fe3\")\n"
"val size = Flagship.getModification(\"btnSize\", -0.1)\n"
"val display = Flagship.getModification(\"displayBtn\", true)\n\n\n"
"val color = Flagship.getModification(\"btnColor\", \"(hello world !)\", true)\n"
"val size = Flagship.getModification(\"btnSize\", \"red, green blue\", true)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.