$re = '/-(?=.* -)/m';
$str = 'My-Cool-String - 201';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;