import re
regex = re.compile(r"-(?=.* -)", flags=re.MULTILINE)
test_str = "My-Cool-String - 201"
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)