package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(news-[0-9]+)`)
var str = `/marketing/news-717777
/finance/news-123456?asdasdasd_asdad`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}