$re = '/(news-[0-9]+)/m';
$str = '/marketing/news-717777
/finance/news-123456?asdasdasd_asdad';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);