re = /(?<remotename>\w*)(?<seperator>\/)(?<branchname>\w*)/m
str = 'origin/master'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end