import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(.)\\1+$)[^\\w\\n]*\\w.*$";
final String string = "11111111\n"
+ "1111811111\n"
+ "rrrrrrrr\n"
+ "rrrrrrrrrr5\n"
+ "11111111%\n"
+ "%$!@$!@@@@\n"
+ "%%%%%%%%%1\n"
+ "a";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}