const regex = /^(?!(.)\1+$)[^\w\n]*\w.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(.)\\1+$)[^\\w\\n]*\\w.*$', 'gm')
const str = `11111111
1111811111
rrrrrrrr
rrrrrrrrrr5
11111111%
%\$!@\$!@@@@
%%%%%%%%%1
a`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}