using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+\.psa";
string input = @"prodigal_per_bin/SAMN07583880/SAMN07583880.psa_megahit";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}