$re = '/\w+\.psa/mi';
$str = 'prodigal_per_bin/SAMN07583880/SAMN07583880.psa_megahit';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);