#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:^ *(?:/\*\*[^/\n]*\r?\n(?:[^/\n]*\r?\n)*[^/\n]*\*/ *|//.*)\r?\n)+(?: *[\r?\n])*#ifdef BUILD_FLAG\r?\n[\s\S]*?^#endif\r?\n"
Local $sString = " Code here" & @CRLF & _
" and here" & @CRLF & _
"" & @CRLF & _
"//this is s comment block" & @CRLF & _
"/**" & @CRLF & _
"*and a nested comment block" & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"//-----------------------------------------------------------------------------" & @CRLF & _
"// this comment block should not be captured" & @CRLF & _
"//-----------------------------------------------------------------------------" & @CRLF & _
"" & @CRLF & _
"//-----------------------------------------------------------------------------" & @CRLF & _
"// this whole comment block and the conditional block below should be captured" & @CRLF & _
"//-----------------------------------------------------------------------------" & @CRLF & _
"/**" & @CRLF & _
" * @brief Some comment " & @CRLF & _
" * " & @CRLF & _
" xxxxx" & @CRLF & _
" * @return " & @CRLF & _
" */" & @CRLF & _
"//-----------------------------------------------------------------------------" & @CRLF & _
"#ifdef BUILD_FLAG" & @CRLF & _
"..." & @CRLF & _
"#endif" & @CRLF & _
"" & @CRLF & _
" More code" & @CRLF & _
"More code" & @CRLF & _
"" & @CRLF & _
"//---------------------------------------------------------" & @CRLF & _
"// this whole comment block and the conditional block below should be captured" & @CRLF & _
"// --------------------------------------------------------" & @CRLF & _
"#ifdef BUILD_FLAG" & @CRLF & _
"..." & @CRLF & _
"#endif" & @CRLF & _
"" & @CRLF & _
"More code" & @CRLF & _
"" & @CRLF & _
" //-------------------------------------------------------------------------" & @CRLF & _
" /**" & @CRLF & _
" * @name this whole block comment should be captured." & @CRLF & _
" * @{" & @CRLF & _
" */" & @CRLF & _
"" & @CRLF & _
"#ifdef BUILD_FLAG" & @CRLF & _
"..." & @CRLF & _
"#endif" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)