import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^ *(?:/\\*\\*[^/\\n]*\\r?\\n(?:[^/\\n]*\\r?\\n)*[^/\\n]*\\*/ *|//.*)\\r?\\n)+(?: *[\\r?\\n])*#ifdef BUILD_FLAG\\r?\\n[\\s\\S]*?^#endif\\r?\\n";
final String string = " Code here\n"
+ " and here\n\n"
+ "//this is s comment block\n"
+ "/**\n"
+ "*and a nested comment block\n"
+ "*/\n\n"
+ "//-----------------------------------------------------------------------------\n"
+ "// this comment block should not be captured\n"
+ "//-----------------------------------------------------------------------------\n\n"
+ "//-----------------------------------------------------------------------------\n"
+ "// this whole comment block and the conditional block below should be captured\n"
+ "//-----------------------------------------------------------------------------\n"
+ "/**\n"
+ " * @brief Some comment \n"
+ " * \n"
+ " xxxxx\n"
+ " * @return \n"
+ " */\n"
+ "//-----------------------------------------------------------------------------\n"
+ "#ifdef BUILD_FLAG\n"
+ "...\n"
+ "#endif\n\n"
+ " More code\n"
+ "More code\n\n"
+ "//---------------------------------------------------------\n"
+ "// this whole comment block and the conditional block below should be captured\n"
+ "// --------------------------------------------------------\n"
+ "#ifdef BUILD_FLAG\n"
+ "...\n"
+ "#endif\n\n"
+ "More code\n\n"
+ " //-------------------------------------------------------------------------\n"
+ " /**\n"
+ " * @name this whole block comment should be captured.\n"
+ " * @{\n"
+ " */\n\n"
+ "#ifdef BUILD_FLAG\n"
+ "...\n"
+ "#endif\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}