package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^a-zA-Z]+`)
var str = ` !
test
1test23
hel lo! what up?!1244`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}