$re = '/[^a-zA-Z]+/m';
$str = ' !
test
1test23
hel lo! what up?!1244';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);