package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[^\d]+|[^\d]+$`)
var str = `foo bar 2022 Nov 22nd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}